Old 05-13-2015, 01:51 AM   #1
Mgoldman
Senior Member
 
Mgoldman's Avatar
 
Join Date: Apr 2006
Posts: 3,569
Default 50 Shades of blue- Calibration issue

Curious - I saw my recently posted image of SOU #630 to RP and on my cell phone (I-phone) has a purplish colored sky. Not much warmth either. I was surprised I uploaded it that way and figured it needed a tweak and re-upload.

When I saw it again on my computer monitor, however, it looked great. Blue sky, nice summer day brilliance and warmth. Back to the I Phone - cool and purple.

What's odd is that another shot looks exactly the same on my cell and monitor - blue sky, some brilliance and a touch of warmth.

How can only one image be off? Checked the profiles - they are the same. How can this be?

This is what I'm seeing -
TOP
What I see on my computer screen (Cell phone capture of the screen).

BOTTOM
What I see on my cell phone screen (Cell phone screen capture of web page).



What color sky is everyone seeing on the Southern #630 photo?

Image © Mitch Goldman
PhotoID: 530706
Photograph © Mitch Goldman


/Mitch
Attached Thumbnails
Click image for larger version

Name:	Colors RP.jpg
Views:	434
Size:	487.5 KB
ID:	8980  
Mgoldman is offline   Reply With Quote
Old 05-13-2015, 03:55 AM   #2
KevinM
Senior Member
 
KevinM's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Posts: 1,834
Default

Mitch,

On my display, that shot of SOU 630 looks just fine. The colors look great.

Time for a new cell phone!
__________________
/Kevin

My stuff is here.

Yeah, I do Flickr too. Tons of non-RP stuff there.
KevinM is offline   Reply With Quote
Old 05-13-2015, 02:05 PM   #3
JRMDC
Senior Member
 
JRMDC's Avatar
 
Join Date: Nov 2006
Posts: 11,191
Default

There is a whole world of sRGB and Adobe RGB and other color spaces, and while I am not familiar with the details, I believe that the problem here is that your cell phone can't process one of those spaces properly.

Looking at EXIF info, the problem shot on the right shows as being in "uncalibrated" color space while the correctly treated shot on the left shows as being in sRGB space. At least the versions uploaded to RP.

This is another way of saying "user error." You saved the problem shot using a bad color space.
__________________
My RP pix are here.
My Flickr pix are here.

My commentaries on rail pictures are in my blog.

RP Photo Albums:
Cabooses
Engine Details
Farm and Train
Plumes!
Railroad Details
Signal Details
Switchstand Shots
JRMDC is offline   Reply With Quote
Old 05-13-2015, 03:54 PM   #4
Mgoldman
Senior Member
 
Mgoldman's Avatar
 
Join Date: Apr 2006
Posts: 3,569
Default

Quote:
Originally Posted by JRMDC View Post
There is a whole world of sRGB and Adobe RGB and other color spaces, and while I am not familiar with the details, I believe that the problem here is that your cell phone can't process one of those spaces properly.

Looking at EXIF info, the problem shot on the right shows as being in "uncalibrated" color space while the correctly treated shot on the left shows as being in sRGB space. At least the versions uploaded to RP.

This is another way of saying "user error." You saved the problem shot using a bad color space.
To the best of my knowledge, all 4 shots have the same color profile.

Not sure what you mean when you say "the problem shot on the right" as all four shots are simply a collage combined into one single image.

Trying to figure out two things here - why/ how can it be that one image would show with a blue sky on my computer monitor, my laptop and my cell phone yet another shows with a blue sky on my monitor, laptop BUT NOT my cell phone, where the Southern (linked) shot somehow shows with a purple sky and a cooler temp.

And, or at the least - what color sky is everyone seeing in the RP linked shot? Bluish or purple sky?

I'll dig deeper into color profiles though they all appear the same, that being:
North American General Purpose 2
sRGB IEC61966-2.1
U.S. Web Coated (SWOP) v2

/Mitch

Last edited by Mgoldman; 05-13-2015 at 03:57 PM.
Mgoldman is offline   Reply With Quote
Old 05-13-2015, 06:35 PM   #5
JRMDC
Senior Member
 
JRMDC's Avatar
 
Join Date: Nov 2006
Posts: 11,191
Default

Quote:
Originally Posted by Mgoldman View Post
To the best of my knowledge, all 4 shots have the same color profile.
I opened up the RP versions of the two shots in question (the two that appear in your four-shot set) and looked at the EXIF info. They do not have the same color profile.

Quote:
Not sure what you mean when you say "the problem shot on the right" as all four shots are simply a collage combined into one single image.
The four shots are two pairs. In the set of shots, the right pair is a wedgie and highway and the left pair is a wedgie and house. I found those two shots on RP and looked at their EXIFs.

Quote:
Trying to figure out two things here - why/ how can it be that one image would show with a blue sky on my computer monitor, my laptop and my cell phone yet another shows with a blue sky on my monitor, laptop BUT NOT my cell phone, where the Southern (linked) shot somehow shows with a purple sky and a cooler temp.
One possibility is that both computer/monitor and phone can handle the sRGB color space in the left image but only the computer/monitor can handle (translate may be the right term) the "uncalibrated" color space specification in the right image.
__________________
My RP pix are here.
My Flickr pix are here.

My commentaries on rail pictures are in my blog.

RP Photo Albums:
Cabooses
Engine Details
Farm and Train
Plumes!
Railroad Details
Signal Details
Switchstand Shots
JRMDC is offline   Reply With Quote
Old 05-13-2015, 08:02 PM   #6
Mgoldman
Senior Member
 
Mgoldman's Avatar
 
Join Date: Apr 2006
Posts: 3,569
Default

Quote:
Originally Posted by JRMDC View Post
I opened up the RP versions of the two shots in question (the two that appear in your four-shot set) and looked at the EXIF info. They do not have the same color profile.
Ah - you are correct. Didn't think to check the RP profiles. Could've sworn they were the same when I looked 'em up in Photoshop. I'll have to double check later tonight.

I looked at the "FxIF" Data. What the heck is "FxIF"? What happened to EXIF?

Anyway, one said "ProPhoto RGB" (the purple Southern shot) while the other said sRGB. I wonder if it had something to do with Lightroom - just started using it.

/Mitch

Edit - on my computer at work, sky's blue, like at home. But still purple on my I-Phone. In fact all the shots, it seems, done in Lightroom yield a purple sky, but only on my I-Phone.

Last edited by Mgoldman; 05-13-2015 at 08:05 PM.
Mgoldman is offline   Reply With Quote
Old 05-14-2015, 01:10 AM   #7
KevinM
Senior Member
 
KevinM's Avatar
 
Join Date: Jan 2008
Location: Massachusetts
Posts: 1,834
Default

Quote:
Originally Posted by Mgoldman View Post
Edit - on my computer at work, sky's blue, like at home. But still purple on my I-Phone. In fact all the shots, it seems, done in Lightroom yield a purple sky, but only on my I-Phone.
Mitch,

When you export from Lightroom, make sure you are exporting the right color space. That export screen has a lot of options. Make sure the correct boxes are checked or very strange things may happen.
__________________
/Kevin

My stuff is here.

Yeah, I do Flickr too. Tons of non-RP stuff there.
KevinM is offline   Reply With Quote
Old 05-14-2015, 04:22 AM   #8
Mgoldman
Senior Member
 
Mgoldman's Avatar
 
Join Date: Apr 2006
Posts: 3,569
Default

Y'know... the problem with Adobe software is you can change the settings at times just by unknowingly hitting a random key. Or, a re-install without your saved settings.

In this case, looks like there's more to Lightroom then simply installing and running with it.

Seems Lightroom - I mean, why would I expect otherwise - has been assigning my images the "ProColor" profile. sRGB by default? Crazy talk.

Thanks Janusz & Kevin- seems that was the issue. Odd, that it was NOT an issue on my computer at home, nor work nor the laptop but only the I-Phone. I've re-uploaded with the sRGB profile. Details at 11.

/Mitch

EDIT: Yup, Lightroom default was "ProColor". Converted all to sRGB and voila - blue skies on the I-Phone.

Thanks!

Last edited by Mgoldman; 05-14-2015 at 04:06 PM.
Mgoldman is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT. The time now is 01:15 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.